WordPress 6.6 将取消对 PHP 7.0 和 7.1 的支持

计划于 2024 年 7 月发布的 WordPress 6.6 将取消对PHP 7.0 和 7.1 的支持。新的最低支持 PHP 版本将为 7.2.24。推荐的PHP 版本仍然是 7.4 或更高版本。

WordPress 目前支持 PHP 7.0 或更高版本。最低支持版本最后一次调整是在 2023 年 8 月的 WordPress 6.3 中,自此之后, 截至 2024 年 4 月, PHP 7.0 和 7.1 的使用量已下降至受监控 WordPress 安装量的 2.45% 。

没有具体的使用百分比规定 PHP 版本必须低于 WordPress 的支持,但历史上项目维护人员使用 5% 作为基准。现在 PHP 7.0 和 7.1 的使用率合计远低于 2.45%,因此在此版本中增加最低支持 PHP 版本的过程可以继续进行。

随着时间的推移,增加最低支持的 PHP 版本的好处会在多个地方体现出来,包括在插件和主题生态系统中、在 WordPress 项目的长期认知中、在开发人员关系中,以及随着时间的推移在 WordPress 代码库及其开发人员工具中。

上一篇:

发表回复

您的电子邮箱地址不会被公开。 必填项已用 * 标注

联系我们

020-2206-9892

QQ咨询:1025174874

邮件:info@361sale.com

工作时间:周一至周五,9:30-18:30,节假日休息

客服微信
购买我们的托管服务器,享受免费运维!